International call add-on not working

Allie
Allie Posts: 3
edited May 2 in Phones

Hi,


I bought an international call add-on $6 for 60 minutes to China and it's in my transaction history, but my phone still doesn't allow me to call. I've tried everything mentioned in the previous posts and NONE of them worked! Please don't repeat the same solutions below but give me the real solution or refund.

I've tried them but still not working:

  1. Turn off the restriction "No International Calls" in advanced parameters
  2. Turn on flight mode for 30 secs and turn it off
  3. Restart my phone and choose Fizz as the network
  4. I'm in my plan coverage area(Quebec) to make the international call

What else I could do? (I'm using iPhone)

Thanks!

Best Answer

  • Jessy_ref_i88b6
    Jessy_ref_i88b6 ⭐ :REFERRAL CODE: ⭐ i88b6 ⭐ :CODE RÉFÉRENCE: ⭐ 🇺🇦 🇺🇦 🇺🇦Posts: 1,531
    edited April 20 Answer ✓

    Hi @Allie

    It seems that you did everything..

    Did you try to call adding the full international code or the + ?

    For example to call france +33 or 01133 ?

    If nothing helps, please contact the support

    You can chat in direct

       •   Sign into your account

        •    Follow the link on this page: https://fizz.ca/en/faq/im-unable-log-my-fizz-account-what-do-i-do

       •   Wait 3 seconds for the green bubble with a '❔' appears at the bottom right of the browser, if you use a phone you must use it in desktop or horizontal mode

       •   Choose the option 💬 chat

       •   If the green bubble does not appear make sure your ad blocker is disabled, otherwise try with another browser.

    Other means of contact

    Whatsapp: (438) 393-5814

    By private message on Twitter: https://mobile.twitter.com/fizz_ca

    By private message on Facebook: https://www.facebook.com/fizzca/

Answers

  • Whizz
    Whizz Posts: 14,303

    Hello Allie,
    I hope you're doing well. 

    I just verified your account and I noticed that the Add-on is indeed showing up on your account, and the No international calls option is turned Off. I can see that you have Quebec coverage, therefore, I would kindly suggest you make sure that you are inside your coverage area when you are placing the call. Also, it would be great if you could use the prefix for China when you are placing the call, If I'm not mistaken, it is +86.

    Cheers!
    -Sergiu

  • Allie
    Allie Posts: 3

    Thanks everyone! It's working! I dialled 086 and 0086 (should be +86) so that's the mistake for the area code

This discussion has been closed.