Internet losing connection

whatever Posts: 1 ✭✭

Hi! I play chess at pro level and I play everyday. The modem is right next to me at all times and I pay for the 120 mbps plan. Yet, three times today the internet went off for about 2-3 minutes at interval of 30min for no apparent reasons. No need to say how infuriating this is. How do I make sure this NEVER happens again? Do I need to get a faster plan? If so, could you mention in the 120 mbps description that it comes with unexpected losses of connections so other clients don't experience the same thing?

Thanks you


  • Dapfizzer
    Dapfizzer Posts: 10,182 ✭✭



    I suggest you to contact the customer service by opening this link: and simply scroll down until you see the green bubble, than click on it to start your chat session with the customer service.

  • Dapfizzer
    Dapfizzer Posts: 10,182 ✭✭

    You also can do it on Facebook:

  • gogoer
    gogoer Posts: 48 ✭✭

    Don’t use fizz modem’s Wi-Fi, only use your own router, it will be fine

  • Whizz
    Whizz Posts: 17,425 admin

    Hi Nick,

    Thankyou for reaching out to us.

    Iunderstand and I'm sorry to learn about the inconvenience.

    Ichecked on your account and on your connection signals from thenetwork to the modem where I can see that they are off from the optimalparameters, with some package loss and broadcast congestions.

    However,there is no incident or maintenance work being performed in the areathat could've caused the disruption.

    Wouldyou kindly please unplug the coaxial cable from the coaxial outletand the modem respectively, wait for about 30 seconds, then plug itback in the outlet first and then in the modem, then restart it?

    Also,please perform a factory reset of the modem by using a sharp objectto press on the small button in the orifice behind the modem for 10seconds, then let the modem reboot itself.

    Followingthis, please change the connection bandwidth setting as shown herebelow:

    Choose: ''My Wi-Fi''
    Select your Wi-Finetwork
    Select: ''Advanced Settings''
    Band Steering ''On/Off''

    Thischange can also be applied through the Wi-Fi modem user interface:
    1.Log in at: fromthe web browser of any device.
    2. Log in using the followinginformation:
    Username: cusadmin
    Password: xxxxxxxx (Passwordyou chose during initial setup)
    3. Go to the next section to applychanges:
    Wireless → General Settings → 5GHz → Band Steering(Disable)

    Then,restart the modem for this change to come into effect.

    Afterthat is done, disconnect your devices from the Wi-Fi (delete theWi-Fi connection from their menu if possible) and connect the onesclosest to the modem on the 5Ghz channel instead.

    More details on how to remedy these cut-offs can be found here:

    Thankyou very much for your understanding, patience and collaboration.

    Havea good one!


This discussion has been closed.