I still cannot receive any text messages

BillCanada
BillCanada Posts: 13 ✭✭
edited February 27 in My Mobile
I see that other people have had the exact same issue going back to one post in this forum from 2018. It is now 2024 and I am having the exact same issue but everyone I have contacted through chat does not have a clue what is going on and how to fix it. They think it has to do with the SIM card but everything else is working. How does that even make sense? Does anyone out there have a clue how to resolve this?

Best Answer

  • Whizz
    Whizz Posts: 19,077 admin
    Answer ✓

    Hello BillCanada ,

    Sorry to hear about this situation. I would suggest verifying if the phone number is correctly registered with your Apple ID, by going to Settings > Apple ID ( your name, usually at the top of the page ) > Name, Phone Number, Email.

    If everything is alright there, make sure that you have the latest update on your phone, and that the time zone is set correctly.

    Lastly, try turning iMessage and Facetime off, restart your phone, and reactivate them. For more information, please refer to this FAQ from Apple https://support.apple.com/fr-ca/HT201422.

    If the issue persists, feel free to reach back to our customer service in private.

    Have a good one!

    -Sergiu, Community Moderator.

Answers

  • elena code xzi4t
    elena code xzi4t Posts: 4,152 ✭✭

    Hi @BillCanada

    Are you able to send them?

    What phone do you have?

    When did you activate the plan? Did you ported the number to Fizz?

    Do you have an iPhone?

    Are you able to try the SIM in a different phone?

  • Andrei_ref_R7VK1
    Andrei_ref_R7VK1 Posts: 6,434 ✭✭

    @Whizz could you please take a look?

  • elena code xzi4t
    elena code xzi4t Posts: 4,152 ✭✭
    edited February 26

    Hi

    I believe that it is a iMessage problem linked with the phone that didn't receive the phone number

    And probably the message are sent by an iPhone to another iPhone

    Probably disabling iMessage will solve (temporary) the problem

    Can you try to disable the iMessage?

    • Go to Settings.
    • Tap Messages.
    • Turn iMessage off.

    Can you also check to go

    • Settings
    • Cellular
    • Check if you see the phone number in Sim


  • elena code xzi4t
    elena code xzi4t Posts: 4,152 ✭✭

    @BillCanada

    Try to ask someone with an android to send you a SMS or someone with the iPhone but ask to disable the iMessage for the test

  • BillCanada
    BillCanada Posts: 13 ✭✭
    iMessage and FaceTime do not work. Under both in settings it says activation unsuccessful. My phone number still does not appear next to where it says Fizz in my SIM cellular settings even when iMessage is disabled. It seems like Fizz is not allowing iMessage and FaceTime to be activated.
  • BillCanada
    BillCanada Posts: 13 ✭✭
    I have disabled iMessage and FaceTime. Makes no difference. It doesn’t make any sense that I would be able to receive text messages from an Android phone and not an iPhone. I should be able to receive them from everyone but I still cannot.
This discussion has been closed.