I bought a travel add on for the US and it’s not working

Options
Deidre
Deidre Posts: 1 ✭✭
edited September 2022 in My Mobile

I can’t figure out how to get it to work and I’ve already read on the forum about similar problems and still cannot get it to work

Best Answer

  • ah727
    ah727 Posts: 818 ✭✭
    edited September 2022 Answer ✓
    Options

    @Deidre

    Go to Connections>>Mobile networks>> and do a network search. You should see T-Mobile or AT&T or both

    If your travel add-on is data, tap on AT&T. If it won't work, search again and tap on T-Mobile

    If your add-on is calling minutes tap on T-Mobile. Your Network mode should be set to include 2G GSM.

    If your travel add-on is data only, and you connect to T-Mobile, you may need to lock in 4G LTE Data. See a recent post on no LTE not in usa

Answers

  • Sean H.
    Sean H. Posts: 186 ✭✭
    Options

    Have you tried restarting your device and reseating the SIM card? Put it into airplane mode for 1-2 minutes then turn back on your cellular. You might need to activate 'roaming' within your device settings. Have you chatted with them via FB Messenger or their website chat?

  • fer
    fer Posts: 28 ✭✭
    Options

    Try to chose another network manually

  • Whizz
    Whizz Posts: 20,650 admin
    Options

    Hello Deidre ,

    Thank you for being part of the Fizz community!
    Also, thank you for everyone who helped him with an advise, much appreciated.

    Following the verifications I see that you contacted us in private and the situation was resolved.
    We remain available 24/7 so please contact us whenever you need following the steps from this FAQ: https://fizz.ca/en/support 
    I am counting on your understanding and I wish you a great day,

    -Georgian

This discussion has been closed.