purchased travel add-on for USA, my phone still shows roaming.

seth Posts: 2

purchased 2GB

travel add-on for USA, my phone still shows roaming.

My data and roaming is on for my phone.

I'm using the hotel's wifi

I need help here or I have wasted $30.


  • Emporium
    Emporium ⭐ :REFERRAL CODE: ⭐ FC9QO ⭐ :CODE RÉFÉRENCE: ⭐Posts: 1,177
    edited November 24

    You need roaming on if you are in the USA and want to use DATA. There is NO extra fees for Roaming with Fizz. It just allows you to connect for Data (as long as you have a package for the desitination). If you don't have Data for the USA, even if you have roaming ON, it won't touch your local data.

    But if you are on WiFi, you phone should Automatically NOT use your Data. If it doesn't, then you can turn DATA off completely when you are on WiFi. Just turn Data on when you need it and don't have WiFi. That way background apps don't use data either.

  • StefanM
    StefanM * Code référence/referral code !! 100$ -> ALXMQ * + 1GB/GOPosts: 1,317

    As @Emporium has already mentioned, you need to enable roaming to make use of your data-add on. Roaming simply means that you are connecting to a network that is not your network provider. For example, I have a Canada Plan. As soon as I travel to Ontario, I need to activate roaming and to use my plan I am roaming.

    So it's perfectly normal. You should be set and good to go! Also keep in mind that Fizz will never present you with a big bill as pay-per-minute rates (i.e. when you don't have an add-on) are always taken out of your wallet. Once those funds are depleted, you won't be able to use your plan anymore.

  • Whizz
    Whizz Posts: 11,118

    Hello seth,

    I am sorry to hear about this situation.
    Please try to restart your phone and verify it connect to a local network automatically.
    If it's not, please try to manually search for the network and connect to T mobile or AT&T mobile. 
    Here you can also find more troubleshooting you can try: https://fizz.ca/en/faq/i-m-outside-my-coverage-zone-and-my-mobile-data-isn-t-working-why
    If the issue still persists please contact our support team to investigate this further.  

    Have a lovely day,

  • seth
    seth Posts: 2

    Hi everyone, I was able to get my data to work. I had to manually connect the service provider to T-Mobile instead of AT&T.

    Thank you all.