Data not connecting while in the US

Has anyone had trouble using data in the US?

I have a Canda+US plan. Data was working just fine here in the US for the past week. But since last night I can't use internet/MMS, and I get a notification asking me to Sign into the network (AT&T). When I click it, it redirects me to fizz.ca/en/jail.

The roaming setting is enabled. I tried everything listed on this page: https://fizz.ca/en/faq/how-do-i-use-my-phone-to-access-the-internet

Nothing worked. For those who had data issues while abroad, what ended up being the fix?

Answers

  • Whizz
    Whizz Posts: 13,452

    Hello jay820i,

    I am sorry to hear about this situation.  
    I can see that you have already contacted our support team and some manipulations were provided.
    Please continue the conversation there to have this fixed as soon as possible. 

    Have a lovely day,
    -Alex

  • Hello, if you've tried all the suggestions on that Fizz support page, I suggest you try each again. Next contact Fizz Customer Service directly under the Contact Form, perhaps there is an issue behind the scenes that is not visible to us customers. You could also back up your data and reset your phone to factory settings and start over but try Fizz Customer Service first, they are helpful.

  • Update: here are suggestions that were made by the support team. None of them fixed the issue but I am sharing them here as they may be helpful to others.

    1. Try connecting to T-Mobile instead of AT&T.
    2. Try deactivating 4G/LTE, test whether it works on 3G

    Since none of the solutions have worked, the support team is opening a ticket with a dedicated unit that will look into the network issue.

  • mcaron11
    mcaron11 Posts: 1

    Were you able to fix the issue ? I have a cabin that is on the US-canada border and I had no problem for a year and then these past couple months, same phone haven't changed anything and aT&T doesn't let me connect anymore

  • Jessy_ref_i88b6
    Jessy_ref_i88b6 ⭐ :REFERRAL CODE: ⭐ i88b6 ⭐ :CODE RÉFÉRENCE: ⭐ 🇺🇦 🇺🇦 🇺🇦Posts: 1,311

    Hi @mcaron11

    AT&T dropped the 3G, can you try with a different provider?

  • Hello @mcaron11, do you have mobile network roaming and data roaming 'on' on your device? If not, reboot your device after switching on. And as others have pointed out switching between automatic and manual mobile network selection and choosing another provider may resolve it as well. Best of luck.