Cannot get my mobile data

Lyonciny Posts: 1 ✭✭

I'm from Montreal and am currently in Ontario. I cannot seem to connect to my mobile data despite having Canada-wide service in my plan.


  • MyriamC
    MyriamC Posts: 920 ✭✭
    edited October 2021

    Is your roaming on on your phone ?

    If you are outside your coverage zone, you may need to activate mobile roaming data.

    The steps to follow to activate mobile roaming data vary depending on the model of your phone. here are two examples:

    AndroidSettings → Mobile network → Roaming

    iPhoneSettings → General → Cellular → Options → Data roaming

    Restart your phone
    1. Reboot (power cycle) your phone by holding down the phone’s start button for 10 seconds.
    2. Following your reboot, your applications will load. Your phone will then re-authenticate to the Fizz mobile network and potentially recover its authorization to access the network.
    Is the Wi-Fi function turned off?
    1. Make sure you have temporarily deactivated WiFi on your phone.
    2. A phone could keep trying to connect only to WiFi when its WiFi function is activated.
    3. Deactivating WiFi, at least temporarily, may enable you to access mobile data.
    4. The process of deactivating WiFi can vary, depending on the type of phone. Here are two examples:
    5. AndroidSettings → Connections → WiFi
    6. iPhoneSettings → WiFi
    Is your APN is correctly set up? (Android)
    2. Steps to follow for configuring the APN can vary from one phone to another. Here's an example:
    3. Settings → Connections → Mobile networks → Access Point Names → APN
    5. Fizz APN settings are:
    • APN:
    • MMSC:
    • MMS proxy:
    • MMS port: 80
    • APN type: default,mms,supl   
    2. If your phone offers you a predetermined APN type, choose “Internet + MMS”
    3. Other fields should be filled by default; if empty, they are not mandatory.
    4. Some phone models use the term “Proxy server” instead of “MMS proxy”. 
    Does the phone choose the right network?
    1. IMPORTANT: Before beginning this process, make sure the SIM card is inserted in your phone. Otherwise, the Mobile networks menu will not be visible.
    2. The steps for enabling your phone to automatically choose a network vary depending on the type of phone. Here are two examples:
    3. AndroidSettings → Connections → Mobile networks → Network operators → Search networks → Automatic/Fizz
    4. iPhoneSettings → Operators → Automatic/Fizz
    5. The frequency band used may vary from one service provider to another. It’s possible that your phone is not able to connect to all available mobile networks.

  • Whizz
    Whizz Posts: 18,400 admin

    Hello Lyonciny 

    I am sorry to hear about this situation.
    Please make sure that your roaming option is turned on and that you are connected to our partner's network Fizz.ext.
    Here you can find more information:
    If by any chance you still experience this issue please reach our support team.

    Have a lovely day,