Website buttons not working

What's up with the website? I tried on Chrome, on Firefox, I can't click on add-on (I'd like to add some data for a trip I'm taking...)

When I click on buttons on the website, nothing happens.

Best Answer

  • Whizz
    Whizz Posts: 10,662
    Accepted Answer

    Hello Dominique N. #39657,

    I am sorry to hear that you encounter this situation.  
    I just verified from my side and everything is working properly. 
    Here you can also find more information about travel add-ons if necessary: https://fizz.ca/en/faq/im-travelling-outside-my-coverage-zone-what-are-my-roaming-options
    I recommend clearing the cookies and cache and trying again after.
    You could also use an incognito/ private browser for this.
    If by any chance you still experience difficulties please reach our support team. 

    Have a lovely day,
    -Alex

Answers

  • Emporium
    Emporium ⭐ :REFERRAL CODE: ⭐ FC9QO ⭐ :CODE RÉFÉRENCE: ⭐Posts: 901
    edited October 5

    @Dominique N. #39657

    Try opening a "Private" window. I just tried it in Firefox and they work fine.

This discussion has been closed.