Roaming in Italy, network not working

Hi all,

I'm travelling in Italy, I just purchased the 5$ 1GB roaming plan but I can't get the network connection to work. I tried changing to the APN of different operators, but it's always the same problem.

I'm attaching the screenshot of the network settings, it's in Italian but I wrote the translation right above.

Any ideas on what I'm doing wrong? Thanks for the help!



Best Answer

  • Whizz
    Whizz Posts: 14,259
    Answer ✓

    Hi Pyr,

    I see you added the right add-on for Italy. Please, try and select the carrier manually in this case and try different carriers - This should do the trick.

    Cheers,

    Jay

Answers

  • PF_Ref_D2U9A
    PF_Ref_D2U9A 🌈🎁 Here's my Fizz referral code. Thanks! 😊 ▶ D2U9A ◀ Voici mon code de référence. Merci! 😊🎁🌈Posts: 2,883

    Hi Pyr

    Can you try manually selecting another provider? Or is TIM the only provider available on your phone?

    Also be sure your phone is compatible with the local network.

  • PF_Ref_D2U9A
    PF_Ref_D2U9A 🌈🎁 Here's my Fizz referral code. Thanks! 😊 ▶ D2U9A ◀ Voici mon code de référence. Merci! 😊🎁🌈Posts: 2,883

    If your account shows that you have purchased the correct travelling add-on, you can contact Fizz customer service by opening this link: https://fizz.ca/en/faq/resolving-issues and simply scroll down until you see the green bubble, then click on it to start your chat session with Fizz customer service.

    They will surely be able to help you.


    You can also do it on Facebook: https://facebook.com/fizzca

    -By private message on Twitter : https://mobile.twitter.com/fizz_ca

    -Whatsapp : (438) 393-5814

  • Emporium
    Emporium ⭐ :REFERRAL CODE: ⭐ FC9QO ⭐ :CODE RÉFÉRENCE: ⭐Posts: 2,157

    I know you are on another carrier network, but did you configure the FIZZ APN settings ?

    Fizz APN settings are:

    • APN: mobile.bm
    • MMSC: http://mms.mobile.bm
    • MMS proxy: mmsproxy.mobile.bm
    • MMS port: 80
    • APN type: default,mms,supl     

    You will NEED to set them as above. Setting them with any other settings (local carrier, videotron, or other) will NOT WORK when you are abroad. So make sure to configure the APN settings acccordingly for FIZZ network.

This discussion has been closed.