my mobile does not ring and shows a missed call

it happens at least once a week where someone tried to reach me and my cell didn't ring. is it because Fizz signal is low or my phone is broken? (note my phone is not 1 year old.......). Has it happened to anyone else?

Best Answer

  • Whizz
    Whizz Posts: 10,662
    Accepted Answer

    Hello @Snoel16

    We are really sorry that you experience this situation,

    I have verified your account and your plan is in good standing and your services fully operational.

    As this situation is encountered only with your incoming calls, I kindly advise you to set up the time before the incoming calls are transferred to your voicemail.

    To do this, please dial this number: *61*+15146470999*11*30#. This will increase the time to 30 seconds before the call is redirected to the voicemail.

    More details can be found here:https://fizz.ca/en/faq/how-do-i-set-up-my-voicemail

    Also, you can try to test the services using the 3G mode.

    To activate 3G mode on your phone, follow these steps: settings> cellular> cellular data option> voice and data> and then choose 3G.

    If these manipulations do not help you, please contact our support team.😊

    I count on your kind understanding and cooperation!

    Have a nice day!

    Eugen

    T

Answers

  • PF_Ref_D2U9A
    PF_Ref_D2U9A 🌈💲🎁 Here's my referral code. Thank you! 😊 ▶ D2U9A ◀💲Voici mon code de référence. Merci! 😊🎁🌈Posts: 1,003

    Hi Snoel

    Have you tried restarting your phone?

    How many bars do you get on your phone? You may also be able to check the signal strength on your phone settings.

  • PF_Ref_D2U9A
    PF_Ref_D2U9A 🌈💲🎁 Here's my referral code. Thank you! 😊 ▶ D2U9A ◀💲Voici mon code de référence. Merci! 😊🎁🌈Posts: 1,003

    If the problem continues, you can contact Fizz customer service by opening this link: https://fizz.ca/en/faq/resolving-issues and simply scroll down until you see the green bubble, then click on it to start your chat session with Fizz customer service.

    They will surely be able to help you.


    You can also do it on Facebook: https://facebook.com/fizzca

    -By private message on Twitter : https://mobile.twitter.com/fizz_ca

    -Whatsapp : (438) 393-5814

  • yeah it has been happening for months actually, my phone has been restarted multiple times since then. iti happens when i have full signal bars as well as low bars. it's odd.

  • PF_Ref_D2U9A
    PF_Ref_D2U9A 🌈💲🎁 Here's my referral code. Thank you! 😊 ▶ D2U9A ◀💲Voici mon code de référence. Merci! 😊🎁🌈Posts: 1,003

    Does this issue happen with all callers or only specific ones? Maybe you have some sort of Do NOT Disturb setting enabled on your phone.

    You can also test your SIM card on another device to see this problem persists.

  • i will try switching my sim card to another device, thanks! it does happen on any call, known users or cpu's. i will miss the call then they try again 3 minutes later and it rings.

  • PF_Ref_D2U9A
    PF_Ref_D2U9A 🌈💲🎁 Here's my referral code. Thank you! 😊 ▶ D2U9A ◀💲Voici mon code de référence. Merci! 😊🎁🌈Posts: 1,003

    It seems your phone is going in "sleep" mode when it has been idle? You can search more online regarding this issue for your phone model.

  • Tadpole
    Tadpole Posts: 28

    The same thing has been happening to me and I have no idea why.

    I can't get any calls from anywhere. It always goes straight to voicemail and I miss it... No ringing.

    I've done all the troubleshooting stuff and nothing seems to change it.

    LG Velvet

  • Did you block some area code I know in settings you can set to block phone numbers and area code so it doesn't ring and event not show the calling display

  • Tadpole
    Tadpole Posts: 28

    Hey I figured it out on mine!

    Months of missed calls, straight to voicemail.

    Priority notifications.... Find in settings.

    I had it set up so that only priority things would come through, yet everything was set as not a priority!!

    It was in the *do not disturb* settings I think. I forgot where it was and can't seem to find it right now.

    Its so *wow* to be able to receive a call again after so many months!!

    I hope this helps someone figure it out too.

  • Tadpole
    Tadpole Posts: 28

    Ok, ---> do not disturb ---> select priorities ----> conversations/calls/messages ---> switch 'em all to everyone.

This discussion has been closed.