Fizz support! many policy and account inquiry and help links are broken

FIZZ: many of your policy links are dead end 404's


and then this one

tried several browser, all dead ends

Best Answer

  • Emporium
    Emporium ⭐ :REFERRAL CODE: ⭐ FC9QO ⭐ :CODE RÉFÉRENCE: ⭐Posts: 518
    edited September 1 Accepted Answer

    @JOHN R. #26386

    The policies above (the links you provided) are both functional for me.

    Are those the ones you are referring to, or other ones ?

    Within that page however, the "how to change mobile plan" takes you to a nothing to see here link - ie: dead link. But the link I provide here works. Seems there is a typo in the link. Remove the trailing characters "%20%C2%A0"

    But the second link works for "how to change internet plans"


Answers

  • Dapfizzer
    Dapfizzer ⭐ :REFERRAL CODE: ⭐ 2PMA6 ⭐ :CODE RÉFÉRENCE: ⭐Posts: 1,822

    @JOHN R. #26386


    Hi John,

    this is the way to contact the customer service by opening this link: https://fizz.ca/en/faq/status-services and simply scroll down until you see the green bubble, than click on it to start your chat session with the customer service.

  • Dapfizzer
    Dapfizzer ⭐ :REFERRAL CODE: ⭐ 2PMA6 ⭐ :CODE RÉFÉRENCE: ⭐Posts: 1,822

    You can also do it on Facebook: https://facebook.com/fizzca.

  • Dapfizzer
    Dapfizzer ⭐ :REFERRAL CODE: ⭐ 2PMA6 ⭐ :CODE RÉFÉRENCE: ⭐Posts: 1,822

    @JOHN R. #26386


    Same for me, all links are functional on 3 different web browsers...🤔

  • JOHN R. #26386
    JOHN R. #26386 Posts: 5
    edited September 1

    that first link ends with this error

    screen grab below. from ONTARIO

    look at the screen grab link in the url bar (latest EDGE)



  • Emporium
    Emporium ⭐ :REFERRAL CODE: ⭐ FC9QO ⭐ :CODE RÉFÉRENCE: ⭐Posts: 518
    edited September 1

    I don't know why your link has a "." at the end of it. When I click the link, I have no "." at end of link.

    Remove the "." at the end of the link and hit enter.

    There is something specific on your device that is adding the "." at the end. I double checked the link you provided and there is no "." in the link you povided, so it must be your browser or some bizarre plugin on your browser causing this.

  • but that is in your link I followed, not added over here...

  • there are many errors like this in the FIZZ web pages, directly captured from the HTML inbound

  • Emporium
    Emporium ⭐ :REFERRAL CODE: ⭐ FC9QO ⭐ :CODE RÉFÉRENCE: ⭐Posts: 518
    edited September 1

    Honestly, I don't see where you get the trailing "." is. In the picture you provided from your browser, there is clearly a "." at the end of the URL. It is neither in any of the links I provided or you provided.

    First of all, that link is from the link YOU provided (I did not provide a link in any of my messages to the main page).

    https://fizz.ca/en/plan-change-policy

    I did provide a link to the sublinks that are on that page:

    https://fizz.ca/en/faq/how-do-i-change-my-mobile-plan (this one is incorrect in the page, since it has trailing garbage characters which should not be there). But this one should work.

    and

    https://fizz.ca/en/faq/i-would-like-to-change-my-fizz-home-internet-plan-how-do-i-do-this


    BTW: are you using any ad blockers ? or PiHole/Adguard DNS server ? Something is changing your URLs.

  • Whizz
    Whizz Posts: 10,134

    Hello JOHN R. #26386,

    I am sorry to hear about this situation.
    I can see that you manage to reach our support team and they were able to assist you.
    Don't hesitate to reach us again if you ever need support.

    Have a lovely day,
    -Alex

This discussion has been closed.