Why are calls to Switzerland not working?

Pierre-Yves Y.
Pierre-Yves Y. Posts: 1 ✭✭

"Your call cannot be completed as this time, please try again later"

I pay for international calls and I have 25 minutes left. The number is correct (it worked last week).

Best Answer

  • Idefizz
    Idefizz Posts: 3,001 ✭✭
    Answer ✓

    Hello @Pierre-Yves Y.

    Has your plan renewed in the meantime with the same option and was kept active? Also, about your minutes, make sure your browser's cache is not showing you the wrong value: logoff, log back in and refresh to make sure.

    Is your callee's phone and network available? Can you try someone else over there?

    Are you set to block outgoing calls? See your Fizz account ► My plans ► Manage plan ► Advanced Parameters

    Here's a tip from a Whizz:

    Please try rebooting your mobile device and after go into your phone's settings and make a manual network switch by disabling the phone's feature to connect automatically to a network and wait a few moments for the phone to verify the available networks for you and connect to a Fizz EXT option network for 30 seconds, then reconnect back to the Fizz network

    Source: https://forum.fizz.ca/en/discussion/2371763/add-international-calls-working

    And another Whizz

    Regarding your international calls, please perform a reboot of your mobile device and after activate airplane mode for 30 seconds then turn it off [...]. Also, make sure that when you are trying to place the call you are inside your plan's coverage area. A few more helpful tips can be found here:

    Source: https://forum.fizz.ca/en/discussion/2394858/add-international-call-60-min-china-can-working


  • Whizz
    Whizz Posts: 20,703 admin

    Hi Pierre,
    Thank you for reaching out to us.

    You can try the indications presented by Idefizz as they can help very much and I'd also recommend you remember to add +41 in front of the number you're trying to call.
    You can turn the Airplane mode on your phone ON and OFF again before restarting it and trying to call again.

    Thank you very much for your understanding.

    Have a good one!


This discussion has been closed.