Cant change my payment method

Im trying to switch credit card for payment and wont let me do it and always says:

you cannot delete this payment method because it is associated to an active account plan. Start by replacing payment method on the plan.

The system wont let me "delete" the original credit card.!!

I'M NOT HAPPY WITH THIS!!!!!

Best Answer

  • Whizz
    Whizz Posts: 10,231
    Accepted Answer

    Hi Mark S. 73969,

    If you check under the first list on the initial link I provided, you can see some steps there and then it says:

    5.For each of your plans, click on Manage plan/Payment method, and associate your new payment method.
    6.Then, select the payment method you no longer want to us, and click on Delete.

    Steps 5 and 6 are crucial since the association of your new payment method to your plans is not done automatically.

    However, we will take your feedback into consideration and see if we can have this webpage be edited and made more clear in the future.

    Thank you for your consideration.

    Andrei

Answers

  • Whizz
    Whizz Posts: 10,231

    Hi Mark S. 73969,
    Thank you for reaching out to us.

    In order to update the payment method on your account, please go to My Settings → Payment Methods and click on Add new payment method:

    https://fizz.ca/en/faq/how-do-i-update-my-payment-method-or-credit-card-information
    Following this, go to My Plans-> Manage Plan-> Payment Method and there you will be able to set it as default. 

    After the new payment method is set as the default, you will be able to delete the old one from My Settings→ Payment Methods.

    Also, please bear in mind that you can only use any Canadian Visa or Mastercard credit card (including prepaid), or a Visa Debit card from official Canadian banks such as TD, RBC or CIBC, as shown here:https://fizz.ca/en/faq/what-payment-methods-can-i-use

    Thank you very much for your understanding.

    Have a good one!

    Andrei

  • Hi Andrei,

    Thank you, it worked!

    However, there is a problem with how the website is set up that there is NOWHERE that indicates customers on How to correctly change "payment method".

    You indicate me to click on "my plan" then proceed which worked BUT however u can as i thought was the logical way was to try on "my settings" which allowed me to proceed to change but did not work in the end.

    Very confusing for NEW customers!!!

    Thanks!

This discussion has been closed.