"See usage" page not loading - No solutions working?

Posting this again since we can't reply to other threads. People have been copy pasting solutions like: change browser, clear cache, use incognito mode.
I'm here to say that NONE of these solutions work and I'm hoping Fizz will take a look at it. It is not normal for users to not being able to see the details of their usage. Also, it is odd because all other pages of the website work.
I've used three different devices/browsers to try and access the "usage" page.

Answers

  • StefanM
    StefanM * Code référence/referral code 25$ -> ALXMQ *Posts: 939
    Ok, I just tried it again on my mobile phone and it works for me.
    Have you tried to reach out to support directly? They website is a bit buggy
  • Replying to StefanM: I did try and reach out and they just said they'd escalate a ticket...I'm new to fizz so that's not fun to see tbh.
  • Whizz
    Whizz Posts: 8,318
    Hello Dominique
    I am sorry for the situation encountered.
    I have verified and see that indeed one of my colleagues escaalated a ticket to our technical team in order to fix this case.
    As soon as we will have an answer from them you will be notified by e-mail address.
    If you have other questions, here you can find how to contact us: https://fizz.ca/en/contact-us
    Have a great day!
    Adelina
  • StefanM
    StefanM * Code référence/referral code 25$ -> ALXMQ *Posts: 939
    I can imagine that it is not great. You don’t have any add/content blocker activated, right ?
  • Turned off ad block, even installed the "app" the browser suggested I install and I get the same loading screen of doom...
This discussion has been closed.