Show my number in outgoing calls

Hello,
I succeeded in blocking my phone number in outgoing calls (for work), but now I am unable to unblock it. I use an Android phone. On the call settings, it indicates "show my number in outgoing calls according to the default operator settings". I tried selecting other options such as "Show number", but when I call my friends still say my number is hidden. Is there a way to fix it? (My number was displayed before, but not anymore)
Thank you

Answers

  • So the number is now shown after I restarted the phone (just did a test call), but after using #31# to hide my number once the subsequent numbers are all hidden even when I don't input the #31# to hide my number. I don't want restart my phone after each call if I need to alternate between hiding my phone number and not. Is there other solutions I can try?
  • Fizzy
    Fizzy  * Code référence 50$ + données gratuites: <66KGA> *  Posts: 6,662
    Hi David

    It looks like you will need to change the setting on your phone calling app.

    For most Android phones, it's on the dialer app or phone settings: Show my caller ID

    Which phone model do you have? You can search online: "how to show my caller id on (your phone model)" to get more details for your phone.
  • Hi David,
    I suggest you try restarting your phone.
  • Hello David!
    Please check the phone settings to see the option "Show number" is on and call your friend with prefix *31#
  • So_AR
    So_AR Posts: 776
    restart your phone
This discussion has been closed.