Block numbers

I have blocked a number from calling me but it keeps leaving me unwanted voicemail. How can I block a number from calling AND leaving voicemail as well? Is there a solution?

Answers

  • Lieux
    Lieux Posts: 2,530
    Alexandre there is no other solution than to block in your settings. Or you can change your number...?
    That’s what a Whizz answers before at the same question Unfortunately there's not much that we can do from our side. To protect yourself from this kind of scams, I would advise you to follow this link: https://crtc.gc.ca/eng/phone/telemarketing/ and to read the information displayed there, as to better understand what this is about and learn how to protect yourself. You'll have chance to register your number on the national Do Not Call List. You can also verify on your phone's menu if you have any option for blocking these numbers. The Canadian telecom industry has also begun to gradually implement universal call blocking to prevent this type of unwanted calls and Fizz is also a part of it. You can find more details on our FAQ: https://fizz.ca/en/faq/universal-call-blocking. As a last resort, you can also change your number from your account.
  • Clive
    Clive Posts: 34
    Contact Fizz. Blocking a number on your device is only at the device level so it won't ring on your mobile. If the number is a spam/scam number you can visit the Do-not-call-list website to add it. If just an individual you do not want calling, Fizz customer service may/may not be able to block it from going to voicemail.
  • Fizzy
    Fizzy  * Données gratuites avec code référence => 66KGA <= Referral code with free data * Posts: 6,840
    Hi Alexandre

    You can disable voicemail by setting up call forwarding to an unknown number from your phone using this guide https://fizz.ca/en/faq/how-do-i-set-up-call-forwarding

    You can also disable your voicemail by removing it from your plan, it will take effect the next cycle.
    Note: This will be a plan change and you will pay the current price. So if you have the old/beta price, it is not recommended to do this.
  • Carlo C.
    Carlo C. Posts: 632
    Alexandre, unfortunately this is a device feature and not a Fizz issue so you won't get a definitive answer but several suggestions. I've Googled the questions and have found this possible solution for iPhone that I don'T know the effectivity of (nothing for Android):
    https://apple.stackexchange.com/questions/329454/how-do-i-block-callers-from-leaving-voicemails
  • Mihai P.
    Mihai P. Posts: 100
    Hi. I found a solution for you for blocking Voice, Text AND Voicemail. Is what you did for Voice, but you have to do the same for each of (Voice, Text or Voicemail). For more info, see here:
    .
    https://support.google.com/voice/answer/115089?co=GENIE.Platform=Android&amp;hl=en-GB
    .
    Hope it help.
  • Whizz
    Whizz Posts: 8,318
    Hi Alexandre,
    There are two way to go about this:
    1. Disable the voicemail option by setting up call forwarding to a number from your phone as you can see on our FAQ here: https://fizz.ca/en/faq/how-do-i-set-up-call-forwarding
    2. Remove the voicemail option altogether from your mobile plan by ordering a plan change that will come into effect starting with the next billing cycle:
    https://fizz.ca/en/faq/how-do-i-change-my-mobile-plan
    Thank you very much for your understanding.
    Have a good one!
    Andrei
This discussion has been closed.