Fizz modem not installing properly?

I received my Fizz modem yesterday, Hitron CODA-4680, and after connecting it correctly with the coaxial cable and the power cord, waiting for the lights to correctly flash there was still no sign of the network written on the Modem. There was only a FizzEV network that I could not connect to with the written password.
I've tried restarting the router or unplugging it many times yet while it always shows the 2.4 network as active it cant be found by any of my devices. I'm wondering if this may be a problem with the coaxial cable since the Videotron guy that came to deliver the modem messed up the cable's wall-socket pretty bad.
Any help troubleshooting would be greatly appreciated.

Answers

  • I would try to contact the support (you can do it with Messenger) if I was in your shoes
  • Please contact the support to fix this situation. Thanks.
  • MichelP
    MichelP code de référence: YJRSP, referral code: YJRSPPosts: 8,720
    Laurent,
    Try a reset of your modem.
    Personnaaly, someone from Fizz Support has ever recommmended me to put in auround 35, 40 second the reset button with a neddle
    Wait 3,4 minutes. To see all the lights on again on your modem.
    I hope it will resolve this problem about your modem.
    If not,
    Ask for support online by chat , this service is available from 8h00 to 21h00, each day.
    Fiirst, connect you to your Fizz account.
    Then, type:
    https://fizz.ca/en/faq/resolving-issues
    Wait a few seconds until you see the green bubble chat down to the right of the page.
    When you see it, click on it.
    Your chat session with Fizz begins.
  • Thanh S.
    Thanh S. Posts: 360
    Make sure everything is properly hooked up and reset
    Otherwise speak with a representative.
  • When the Videotron is at your place, he tests that the connection works before leaving. Therefore that should not be the problem. Did you try unplugging and reconnecting the coaxial cable as well? If not try that, also try doing a factory reset.
  • Whizz
    Whizz Posts: 10,316
    Hello Laurent,
    Thank you for bringing this to our attention.
    We've already chatted about this situation a couple of minutes ago. We've tried together some troubleshooting steps and we settled that a technician should come at your address to make further verification. I really hope it will be resolved and you'll be able to use our internet service.
    Have a nice day!
    Radu
  • Thanh S.
    Thanh S. Posts: 360
    Now please close the thread
  • Beter
    Beter Posts: 131
    Did the tech test the cable?
    They usually test the cable to make sure it s active.
    I would chat with the support having the serial number of the modem to make sure it's reaching their end and registering on the network.
  • Sounds like your theory might be right, it's too bad the technician messed up your wall socket! I'd mention that to support and have them send another technician to remedy the situation.
  • If you have solved your problem, please choose the best answer to close the discussion.
  • K L.
    K L. Posts: 209
    and the issue of your trouble ?
    If all's good, t y too chose the helpfull answer to close the question.
  • Is it fixed ?
This discussion has been closed.