Cant transfer my sim ?

Options
So my phone got stolen and i deactivated my sim card, ordered a new one, then clicked on activate your sim card, then i realized that i had to do it on my plans tab, so i got out of the activate my sim tab (i didnt finalize anything) and when i clicked on transfer sim card it said that the new sim i just ordered is invalid...

Answers

  • Calintz
    Calintz Posts: 49 ✭✭
    Options
    I suggest you to contact Fizz directly via the chat here:
    https://fizz.ca/en/contact-us
  • DinoS
    DinoS Posts: 626 ✭✭
    Options
    Fizz can fix it, but I was told SIM card is re-usable.
    Go to https://fizz.ca/en/contact-us, wait 10 seconds, click green bubble on bottom right, and start chat
  • James M. #1533
    James M. #1533 Posts: 88 ✭✭
    Options
    Contact Fizz and ask them for a new SIM because this isn’t normal.
  • Mohamed D. #1615
    Options
    So i contacted the team and the guy had no idea why this was happening, he said he escalated it to the "expert team" and closed the convo, i have no idea what to do now. Its still happening :/ here are some pictures (the second one is the regular activation (wich i didn't know was different), and the first one is the actual feature im trying to use (transfer sim card)
  • Whizz
    Whizz Posts: 20,107 admin
    Options
    Hi Mohamed,
    Your issue has been escalated towards our technical team, so unblock the code because you used it once when you tried to activate a new plan.
    This situation has been solved and you can try again to activate your SIM card.
    Have a great day.
    Luciana
  • Anne H. #1344
    Anne H. #1344 Posts: 648 ✭✭
    Options
    Use replace sim