BMO.com website and app not working?

I am unable to access BMO.com or BMO app from my phone over cellular data. With Wi-Fi it works fine. It may appear that bmo has blacklisted Fizz’s IP or subnet. Anyone having this issue?

Answers

  • I don't use BMO but I confirm on my phone as well I can't reach the site. Same error as you.
  • Probably a problem with BMO since it's a 404 error means that you can reach the site, but the page is missing. I just tried it right now and it is working properly without the 404 error now.
  • Just tried and I get the same error 404 error on data, but on Wifi it works.
  • M T. #338
    M T. #338 Posts: 2,940
    It must be related to Fizz mobile networks.
    I'm able to connect to https://bmo.com using another mobile provider.
  • DavidP
    DavidP Posts: 300
    I just tried and it works fine for me on Fizz and on Wi-Fi
  • M T. #338
    M T. #338 Posts: 2,940
    It's working now. I didn't earlier.
  • It appears not to be working again.
  • Whizz
    Whizz Posts: 10,316
    Hello Sami Sheikh ,
    I am sorry for your situation.Please delete your phone's browser cache.Also consider clearing your browser's cookies or at least the one(s) involved with the website in question if clearing the cache didn't work.If the issue still persist please contact us via chat or Facebook Messenger.
    Have a nice day!
    Marius Daniel
This discussion has been closed.