Globe Electric Smart Bulbs: Some Working, Some Not

PeterG Posts: 8 ✭✭
edited September 2021 in Internet

Hi -

I have several Globe Electric brand smart bulbs.💡 Some have stopped working and show as "offline," while others continue to work fine. Has anyone else had this problem? If so, how did you fix it?🛠️ Is band steering (switching from 5g to 2.4g) the answer? If so, why do some still work? I don't want to knock other devices offline if I disable band steering.💻️ P.S.: Bulbs are all 6 months old, so end-of-life doesn't seem to be an issue. Thanks!


  • PF_Ref_D2U9A
    PF_Ref_D2U9A Posts: 4,912 ✭✭

    Hi Peter

    I believe these bulbs will work only with the 2.4GHZ signal.

    It looks like you have 2 choices

    Either disable the band steering option or you can disable the 5 GHZ signal if you don't need it.

    If you have too many devices connected to Wi-Fi (more than 10?), this can be an issue too.

    Some members have reported better experience by using their own router for Wi-Fi and putting the Fizz modem in bridge mode.

  • PF_Ref_D2U9A
    PF_Ref_D2U9A Posts: 4,912 ✭✭

    If the problem continues, you can contact Fizz customer service by opening this link: and simply scroll down until you see the green bubble, then click on it to start your chat session with Fizz customer service.

    They will surely be able to help you.

    You can also do it on Facebook:

    -By private message on Twitter :

    -Whatsapp : (438) 393-5814

  • gogoer
    gogoer Posts: 48 ✭✭

    use wifi of your own router, not fizz modem's wifi.