Fizz isn't letting me add data on?

Cambria Posts: 25 ✭✭
I've blown through my data for the month (woops!) but when I try and add anything or modify my plan, I keep getting a banner warning at the top of the screen saying that there were "several changes" and that they need to be processed before I can do anything else. I literally haven't done anything since last month or the one before, so I have no idea what they're on about. Anyone else have this issue? Is there anything to do about it?


  • Genoveva
    Genoveva Posts: 27 ✭✭
    I hope it gets solved soon.
  • GOAT
    GOAT Posts: 227 ✭✭
    Very strange... Maybe someone has some extra data they can gift you?
  • Elizabeth B. #5037
    Elizabeth B. #5037 Posts: 80 ✭✭
    You could try waiting a bit before trying again, or maybe using a different device or browser. If that still doesn't work then I'd contact fizz support. Hope it gets resolved
  • Whizz
    Whizz Posts: 17,425 admin
    Hello Cambria,
    As I have checked your account I see that you already purchased an Add-on. I assume that there were an issue related with your browser and now everything is fixed.
    Have a good one!
  • Kovid
    Kovid Posts: 581 ✭✭
    Sometimes, the banner would indicate an error but the transaction did go through.
    It happened to me!
This discussion has been closed.