Use data-plan for mobile WiFi device?

PJ46
PJ46 Posts: 6
edited December 2023 in My Mobile
I was given a Huawei E5577s-932 Mobile WiFi device (purchased in Saudi Arabia; device is unlocked now) and would like to know if it is compatible with Fizz's network? I already tested inserting my current SIM (inside Android device) and the mobile WiFi keeps defaulting to "Roaming" in 2G on "ROGERS" network. Any ideas?

Best Answer

  • CandyCris
    CandyCris Posts: 501 ✭✭
    Answer ✓

    A quick search shows: Huawei E5577s-932: Band 3/7/28/40 (FDD 700/1800/2600MHz,TDD 2300MHz)

    and Fizz requires:

    A phone that only allows 3G configuration or HSPA network preference must support:

    • The dual frequency 1700/2100 MHz (also called AWS)


Answers

  • CandyCris
    CandyCris Posts: 501 ✭✭
    edited November 2023

    You can check here and see if your device has the required frequencies:

    https://fizz.ca/en/faq/compatible-devices

  • M T. #12340
    M T. #12340 Posts: 561 ✭✭
    edited November 2023

    Did you define your APN https://fizz.ca/en/faq/what-are-fizz-network-settings-apn


    Fizz APN settings are:

    • APN: mobile.bm
    • MMSC: http://mms.mobile.bm
    • MMS proxy: mmsproxy.mobile.bm
    • MMS port: 80
    • APN type: default,mms,supl   


  • Jess_i88b6
    Jess_i88b6 Posts: 12,839 ✭✭

    Hi @PJ46

    If the @CandyCris information are for your device, this is not compatible with Fizz, since Fizz needs Band IV

  • Easygolucky
    Easygolucky Posts: 1,089 ✭✭

    Using a Huawei E5577s-932 Mobile WiFi device with Fizz's network involves a few considerations to ensure compatibility and proper functioning. Here's a breakdown of what you might need to check:

    1. Network Compatibility: First, ensure that your Huawei device supports the frequencies and bands used by Fizz. Fizz operates on specific LTE and HSPA bands. You'll need to check if your Huawei device supports these bands. Since it was purchased in Saudi Arabia, there's a chance it might not fully align with North American network standards.
    2. APN Settings: Since you've mentioned the device is already unlocked, the next step is to configure the APN settings for Fizz. The device needs to be set up with Fizz's APN information for it to work correctly on the network. You can find the APN settings on Fizz's website or community forum.
    3. Roaming Issue: It's interesting that the device is defaulting to "Roaming" on the Rogers network. This could be due to the device's configuration or it not fully supporting the local network bands. Since Fizz uses Rogers' network infrastructure in certain areas, your device might be recognizing it as a roaming network due to its original regional settings.
    4. 2G Connection: Fizz primarily operates on 3G and 4G networks. If your device is only connecting to 2G, this could be another indicator that it's not fully compatible with Fizz's network frequencies. Modern Canadian carriers, including those whose infrastructure Fizz uses, are predominantly focused on 3G, 4G, and LTE networks.
    5. Manual Network Selection: Try manually selecting the network on your device. Sometimes, setting the device to automatically choose a network can lead to it selecting a roaming network. Manual selection might allow you to connect to the appropriate Fizz network.
    6. Check with Fizz Support: If you're still having trouble, I'd recommend contacting Fizz support. They can offer more detailed assistance, especially if there's a specific compatibility issue with your device.
  • PJ46
    PJ46 Posts: 6
    @CandyCris, @Jess_i88b6, thanks for sharing. This is interesting; so this device may be able to be utilized with other carriers (Rogers, Telus, Bell etc.) given they may be using other bands?
  • PJ46
    PJ46 Posts: 6
    > @Jess_i88b6 said:
    > Hi @PJ46
    > If the @CandyCris information are for your device, this is not compatible with Fizz, since Fizz needs Band IV

    > @CandyCris said:
    > A quick search shows: Huawei E5577s-932: Band 3/7/28/40 (FDD 700/1800/2600MHz,TDD 2300MHz)
    > and Fizz requires:
    > A phone that only allows 3G configuration or HSPA network preference must support:
    > The dual frequency 1700/2100 MHz (also called AWS)

    @CandyCris, @Jess_i88b6, thanks for sharing. This is interesting. It is possible that this device may work (3G and/or 4G) with other carriers (Bell, Rogers, Telus etc.) given they may be using other frequencies/bands? Will look more closely at this then.
  • PJ46
    PJ46 Posts: 6
    > @M T. #12340 said:
    > Did you define your APN https://fizz.ca/en/faq/what-are-fizz-network-settings-apn
    >
    > Fizz APN settings are:
    > APN: mobile.bm
    > MMSC: http://mms.mobile.bm
    > MMS proxy: mmsproxy.mobile.bm
    > MMS port: 80
    > APN type: default,mms,supl   

    Yes. the device only has a field for "Name", "Username", "Password" and "APN". I used the existing APN information from the android device (Name = "mobile.pm", APN = "mobile.pm") and Name = "Fizz", APN = "mobile.pm", but it still defaults to the 2G, roaming on Rogers. Will look into other carriers to use this device; perhaps they utilize frequencies that are compatible with this device.
  • Jess_i88b6
    Jess_i88b6 Posts: 12,839 ✭✭

    You have a typo (I believe), you wrote mobile.pm instead of mobile.bm

  • CandyCris
    CandyCris Posts: 501 ✭✭

    If you have an old IPhone or android phone, you can also use that to create a hotspot.

  • PJ46
    PJ46 Posts: 6
    > @Jess_i88b6 said:
    > You have a typo (I believe), you wrote mobile.pm instead of mobile.bm

    Yep, it's a typo. I did use the correct APN Settings in the device's fields (Name = mobile.bm, APN = mobile.bm) and it will only detect/connect to Rogers 2G, roaming. Will look into Bell, Rogers or Telus to use this device.
This discussion has been closed.