Here's how to connect a USB disk to your Fizz modem and access it on your network

Fizzaro Posts: 2 ✭✭
edited August 2022 in Internet

Preface: I was having a bit of trouble figuring this out, but thanks to a few useful threads in this forum, a bit of search on Reddit and a bit of tinkering, I finally figured it out, so I'm compiling a bunch of useful information here to help the next person in this situation.

Selecting a disk (USB device)

First, you will need to choose a disk that connects via USB. In my case, I had a USB key laying around, so I used that. But in theory other devices like external hard drive, external SSD and micro-SD card with a usb adapter should work too. I'll call that "disk" for simplicity but you can call it whatever you want.

You will need to erase & format your disk, so make sure to back everything up onto a different disk before moving on.

Formatting disk

You will now need to format your disk. The format needed is FAT32 [1], or FAT16 if you are using a disk with very low storage. This is different from other popular disk format (NTFS, exFAT). There's different ways you can do this.


After you connected your USB key to your Mac, open "Disk Utility", and under "External" on the left bar, you will see your USB key. Click on "Erase" on the top right and choose "MS-DOS (FAT32)" or "MS-DOS (FAT16)". This will format your usb key after erasing everything.

Windows 11

I have not tried, but this may help:

Android 11+

You will need a dongle that connects usb-c (modern android phone port) from one side and usb-a (the port of your usb key) on the other side. Now, if you are using a modern version of Android (e.g. 11, but other versions might work), you can open "Settings", then select "Storage", and you should see "This Device", then change that to "USB Drive", and you should see something like this:

Then click on the three dots on top right corner and select "Format". You will see this:

When you click on "Format USB drive", this will erase all the files and format your usb drive into FAT32 (or FAT16 if it's small) automatically. Once that's done, you can remove it and connect it to another device to verify that it is indeed in the FAT format.

Connect to network drive

You can now plug your newly formatted drive to your modem. Then, you can try to access it on your local network via the Server Message Block 1 (SMB1) protocol. The following information will be useful [2]:

  • Username: cusadmin
  • Password: <the password that you set for your wifi network>


You will need to install an app on Play store that supports SMB. For example, you can use the "File Manager" app with over 50M downloads. Then, you select "Remote -> Add a remote location -> then enter in host, then the username and password above.

If you use an app like Solid Explorer, you can click on the three bar button -> three dots button -> Storage Manager -> the "+" in a circle button on the bottom right, then choose "LAN/SMB". It won't find it automatically, so you will need to enter the information above (including the host). Then, make sure to select "Yes" when asked "Set advanced?" and select "SMB1". Finally, press connect and it should work.


Open your browser, and type in: smb:// and this will prompt you to open your Finder. You will then need to sign in (see above). Then you should be able to access the files.


I have unfortunately not tried, but the following might help:




Best Answer

  • Emporium
    Emporium Posts: 2,296 ✭✭
    Answer ✓

    If you value the security of your network, DO NOT DO THIS.

    SMB1 is disabled by default in most modern OS for a reason. It is VERY insecure. It is the prime target for viruses and worms to propagate though your network. It is over 30 yrs old and there is a reason it has been discouraged for the last couple of years.

    Quick google search for SMB1 will show you many articles published, even by microsoft about the security issues.


  • Vasiok
    Vasiok Posts: 1,039 ✭✭

    Thank you for sharing this useful information with us!

  • D_M_O
    D_M_O Posts: 126 ✭✭

    thanks a lot!

This discussion has been closed.