Waze issues on Fizz data

Options
Fanni
Fanni Posts: 41 ✭✭

Hi

Today when I tried to use Waze for navigation, it says a variations of "Searching network" or "No Connection" or "No GPS - showing your approximate location" etc. I have turned Location Services on my iphone for Waze, cellular on (there's enough data in my plan). I had this problem going somewhere and also when I was trying to leave Laval heading back home.

I had shutdown my phone and tried again. It didn't work for heading to my destination but luckily I didn't get stuck too much on the detour for highway 13 and guided my destination okay. Also for my return home, it didn't work initially. Maybe it's because of parking garage structure? I tried again to shutdown my phone once I pulled over and away from that area and then it seemed to work again.

This is the first time that I'm experiencing this when using Waze with Fizz data. Has anyone had similar experience in the past? Why is this happening and what I can do to avoid it?

Thanks in advance.

Answers