Can't register for a plan, the website just spins at various points and I never make it to the payme

I have tried different browsers but I never get to complete my application for internet services. It just goes blank at various points, including logging in. I have made it once as far as appointment date but most of the time it blanks at log-in. The actual log in form disappears.

Answers

  • Justin
    Justin Posts: 888
    Hi Terry,

    Did you try to connect on a private navigation?
  • Terry K.
    Terry K. Posts: 2
    Tried that Justin and when I got to the sign in page it said - there is a problem, please try later...
  • Took me a few days when I signed up. I recommend to try a different browser, ultimately that is what worked for me.
  • Justin
    Justin Posts: 888
    As Emmanuel said, try a different browser. If nothing work, you should contact Fizz support.
    To contact support by chat you must be within hours of operations for a quick response, otherwise leave your message and they will contact you.

    1- Log in to your account

    2- In the right corner (bottom) click on the “?” and leave a message on one of the platforms:
    Messenger
    Twitter
    WhatsApp
    iMessage

    Have a good day
  • Fizzy
    Fizzy  * Code référence 50$ + données gratuites: <66KGA> *  Posts: 6,673
    Hi Terry

    Try clearing your browser cache and open a new tab in private mode. You may also try with a different browser or another device.

    When you get to the last step, try selecting a different appointment date (instead of the one you tried previously). Let us know if this works.
This discussion has been closed.