Final step (confirming the tech appointment) does endless charging icon

Hi,
I'm trying to buy a plan and schedule the appointment, while doing the final steps on the webpage,(and confirming the details), the Fizz logo just does an endless loop. Also, some webpages before were a bit glitchy, had to refresh a lot to see it properly.
Does the website experience some troubles? I tested multiple browsers and os, pretty much the same everywhere.
Thanks.

Answers

  • MichelP
    MichelP code de référence: YJRSP, referral code: YJRSPPosts: 8,732
    Louis,
    Thank you for your answer and you have solved yourself the difficulty to fix the appointment with the technician for your installation of internet.
  • Hi this happened to me before, under the exact same circumstances. Regardless of which browser I tried. The Fizz team was super helpful. Under the "Help" tab, then contact us, I chatted with their team. It was explained to me that once in a while the situation that you mentioned can occur. They got back to me under 48 hours and everything was solved! Appointment booked too! You can even chat with Fizz on their Facebook page. https://www.facebook.com/fizzca/
  • StefanM
    StefanM * Code référence/referral code !! 50$ -> ALXMQ * + 1GB/GO (DM me for GB/GO)Posts: 1,443
    Usually the Fizz Support Team is very helpful in this regard and they can schedule an appointment for you :)
This discussion has been closed.