I am having issues with my fizz router (co ac cable issue)

Ardo Posts: 1 ✭✭
I have installed my Fizz router as of October 1st and followed the steps provided. My issue is that once the co ac cable was plugged in instead of seeing all the lights on the modem flash blue, I only get a green download button flashing, which means it's still looking for a signal. I see the WiFi pop up but when I access it there is no internet connection.
3 lights that are on:
Download (flashing)
And the 2.5g network button at the bottom.
I tried plugging it into every possible cable In my flat and am at the end of my wits.
Would really appreciate help asap
(and yes I have tried rebooting or letting it try to find the signal for a good 30 mins on every wire)


  • So_AR
    So_AR Posts: 776 ✭✭
    Did you install it with the application? I know that I had issues if it didn't use the app
  • Mike
    Mike Posts: 20,182 ✭✭
    Hi Ardo,
    The download flashing means that you have problem you the coaxial cable signal

    Please unplug the modem from the power outlet and verify if the coaxial cable is tightly screwed in both ends, preferably to fully unscrew from both sides, then connect it back in to make sure it is properly connected. If the issue still persists, please take a look over the link below which has a few useful tips as well:

    In case it still will not reconnect, please contact Fizz directly by chat using the link above.

    here's how to contact customer support by chat, from 8 AM to 9 PM everyday:

    1- Connect to your Fizz account (if you have more than one, connect to the one that has the problem) by clicking « Login » in the top right corner at fizz.ca
    2- Click on this link: https://fizz.ca/en/faq/none-my-devices-can-access-internet-wi-fi-or-using-cable-how-do-i-fix-it
    3- The green chat bubble should appear after a few seconds in the bottom right corner.

    Do not hesitate to mark this answer as the best
This discussion has been closed.