No data on R-SIM unlocked iPhone?

Options
Danny R. #26821
Danny R. #26821 Posts: 3 ✭✭
Hello everyone, new user here. So I have and use an iPhone 6s which is R-SIM unlocked. I tried downloading both Videotron profiles from unlock.co.nz (as they don't have the Fizz APN) and with either profiles I see Fizz LTE but data is not working.
I know it would probably be easier to get my 6s factory unlocked but it's a KDDI iPhone and it's well over a hundred dollars to factory unlock... so R-SIM while not ideal has worked very well for me so far.
Anyone encountered a similar issue?
TIA

Answers

  • Stéphane L. 1007
    Stéphane L. 1007 Posts: 271 ✭✭
    Options
    What is R-SIM?
  • Danny R. #26821
    Danny R. #26821 Posts: 3 ✭✭
    Options
    It's an interpreter device that can unlock iPhones that have not been factory unlocked by Apple. Using a code you can trick the iPhone to think it's factory unlocked and work with most carriers.
    Data worked fine on Virgin Mobile with the Bell APN but I have had no luck using the Videotron APN.
    Update -- mystery solved. With R-SIM LTE usually takes up to 24 hours to activate after powering on/toggling airplane mode. It is nearly instantaneous with my Fizz SIM, but data does not go through so I have to downgrade to 3G and periodically test for connectivity. The APNs were correct after all.
  • Victoria C. #24523
    Victoria C. #24523 Posts: 367 ✭✭
    Options
    Data is supposed to be working with anything above iPhone 5c I believe. Contact fizz support to solve this issue.
This discussion has been closed.