Chromecast doesn't work when I disable band steering?

Hello everyone, I hope you are well!
So I recently disabled band steering on the Fizz app to split the 2.4 & 5GHz signals manually.
Everything works fine except my Chromecast. It setups and connects to the network but then it just won't cast anything. Yes, it's on the same network (2.4GHz) as my phone. Yes, I tried resetting and rebooting the Chromecast multiple times, deleting the YouTube and Netflix app, rebooting my phone, unplugging the modem, nothing works. The only way to make it work is by re-enabling band steering. I even contacted the Google Support team and they couldn't fix the issue, asking me to contact my ISP.
The Fizz chat box isn't showing up anywhere so here I am.
Thanks in advance for your help.

Answers

  • Mike
    Mike Posts: 19,244
    The device and chromecast are on the same wifi?
    Did you disable also the ATF?

    .
    - Go to this page https://fizz.ca/en/faq/how-do-i-configure-my-device-wi-fi-network, if you are not connect login
    - The business hours: every day from 8 a.m. to 9 p.m. (EST).
    - Wait 5 seconds for the bubble icon to appear at the bottom right of the browser and click on the icon to chat with support. Try a different browser if you have issues getting the bubble to appear.
    .
    If the chat bubble does not appear, this means that the number of sessions waiting for our answers surpasses our processing capacity. If that happens, send us a private message via Facebook Messenger or Twitter.
  • Qulbut
    Qulbut Posts: 2,035
    If they don't fix the issue the first time try again because they don't have all the same knowledge
  • Good evening thomas
    After all the good explanations from the fizz members.
    If that is still not resolved. I advise you in chatted with fizz via the chat bubble or via messenger from their page. They will be able to solve your problem. Good night
This discussion has been closed.