Why My internet speed is 20 mb when my plan is 60 ?

Options
Vasile L. #21040
Vasile L. #21040 Posts: 1 ✭✭
Internet speed is very low 20 out of 60?

Answers

  • Qulbut
    Qulbut Posts: 3,669 ✭✭
    Options
    Contact the support for help on this situation. A lot of people have the same issue since a few days.

    CHAT
    Go to this page https://fizz.ca/en/contact-us , if you are not connected login
    The business hours: every day from 8 a.m. to 9 p.m. (EST).
    Wait 5 seconds for the bubble icon to appear at the bottom right of the browser and click on the icon to chat with support. Try a different browser if you have issues getting the bubble to appear.
    If the chat bubble does not appear, this means that the number of sessions waiting for our answers surpasses our processing capacity. If that happens, send us a private message via Facebook Messenger or Twitter.
     
    FACEBOOK
    Your can also send a message via facebook messanger https://facebook.com/fizzca and click send a message (this is a bit slower)
     P
    CONTACT FORM
    You can also fill a contact form from your account Once logged in, from the account panel go to My Profile → Contact Form (the subject are limited) and fill out the form and someone will email you back.
  • Mike
    Mike Posts: 20,969 ✭✭
    Options
    Can you try to make a test with the Fizz applications or a computer connected with the ethernet cable direct to the modem?

    I will try to disable the wifi steering and the ATF
    https://fizz.ca/en/faq/my-wi-fi-network-slow-how-do-i-make-it-faster

    With the band steering function, only one Wi-Fi network name will be displayed. Each compatible device will automatically connect to its optimal frequency (2.4Ghz or 5Ghz) to make the user experience seamless.

    - Use a PC, open a browser and go to http://192.168.0.1
    - The username is "cusadmin" and the password should be your Wifi password
    - Go to "Wireless" then "Basic setting" then "5G"
    - Set "Band steering" to "Disabled"
    - Then go to "ATF" then "2.4G"
    - Set "ATF Enable" to "Disabled"
    - Go to "5G"
    - Also set "ATF Enable" to "Disabled"
    - Save Changes
    - Wait for the modem to reboot
  • Isabelle P. #15966
    Isabelle P. #15966 Posts: 832 ✭✭
    Options
    I advise you in chatted with fizz via the chat bubble or via messenger from their Facebook page. They will be able to solve your problem.
  • Pablo F.
    Pablo F. Posts: 2 ✭✭
    Options
    Hello, did you try the speed white connected directly to the modem without a router?
This discussion has been closed.