Router not letting me change the admin password?

I had to do a factory reset of the router after activating guest network and getting kicked out of the router completely.
I then connected to the router via LAN cable, and followed instructions at to name the wifi network and give a password.
Then I went to to administer the router, logging in with cusadmin and the network password.
I am trying to change the admin password. It won't let me. It keeps saying:
Incorrect Old Password!"
I have tried the following passwords: the wi-fi password, the default password on the back of the router, may old admin password (the last time I had changed it). I keep having the same problem.
But I have no problem logging into by using the wifi network password, which is weird.
Please advise.


  • Oh this is strange
  • MichelP
    MichelP code de référence: YJRSP, referral code: YJRSPPosts: 8,732
    I think a reset of your Fizz modem can resolve this problem.
  • poker85
    poker85 Posts: 778
    Yes, try to reset of your Fizz modem :)
  • Sounds like you tried everything. As other mentioned, the password is case sensitive, so try that. If that doesn't work, do a factory reset again. Good luck.
  • Martin
    Martin Posts: 271
    Did it work? If not , try contact the with messenger
  • hc0468
    hc0468 Posts: 168
    Make sure you have the same keyboard layout as you did when setting the password. That could result in different characters being entered.

    If nothing else works, maybe it's time for a reset. Strange issue for sure.

    One other thought is that sometimes password entry fields don't do proper input validation. Sometimes they let the user enter a password that is longer than allowed or contains characters that are not allowed, and silently truncate. Then no matter what you enter, the password doesn't work. So try to avoid obscure characters and immediately test passwords by trying to login. If it fails and you're sure you entered it correctly then reset and try setting a different password. There are many websites that fail on this...
This discussion has been closed.