Unable to unlock phone initially with Fido, transfered to Fizz. Fizz blames Fido, Fido blames Fizz?!

Recently transfered my mother's phone (Samsung Galaxy A5, running Android 8.0) from Fido to Fizz. The phone displays a message asking for a code 'PUK for the SIM network' because the 'SIM network NIP has been blocked'. I have tried the unlock code received from Fido, the Fido PUK code and the Fizz PUK code that I found in my mother's Fizz account and none works, all display a 'failed to unlock' message. If I put the Fizz SIM card in my phone which is unlocked, no code is requested and the phone (receiving and sending SMS and calls works under my mother's phone number). Putting, my SIM card (also Fizz) in my mother codes and the same message requests again the PUK code. All 3 fails. I have been chatting with both Fizz and Fido for hours and both keep sending me back and forth to the other provider saying that the issue does not come from their side and that they cannot help me, so no progress have been made. Great! :( From the Fizz side, they say that they do not lock any SIM card and the fact that the card worked in an unlocked phone shows that the issue comes from the phone not the card, so I need to contact FIdo who locked the phone. Fido, on the other side, says that the phone requires a PUK for the SIM network, which since Fizz is the provider for that SIM card, means that I have to contact them instead because they cannot give me codes from Fizz. Both sides are aware of what the other side is saying and neither will change their speech even though all they keep saying is to ask the other side for the code but that they are well aware that all codes tested did not work. So I am asking for help from other Fizz customers who might have had similar issues.


This discussion has been closed.