Slow transfer speed for USB attached drive ?

I attached my 3TB USB hard drive to my Fizz router but I'm getting very slow transfer speeds of only 1MBps. I tried accessing the drive from both a Win 7 and a Win 10 PC but I'm getting the same slow speed. I figured it should be able to transfer at least 10MBps considering the specs of the Fizz router. Anyone have experience getting faster speed out of this router ?

Answers

  • Mike
    Mike Voici mon code de référence => K61CD <= Here my referral code => K61CD <=Posts: 19,179
    The USB 3 is 640MBps the USB2 is 60Mbps therefore you are too slow.
    Are you connected in WiFi or ethernet?
  • DinoS
    DinoS Referral Code: M7IQ8Posts: 614
    Yes it's very slow. Same for Rogers modem
  • Lopresor
    Lopresor Posts: 257
    What type of USB hard drive do you have attached ? You need to find out what's causing the bottleneck and in your case, I believe it's your hard drive.
    Do you have a USB 3 usb stick ? Or a different USB 2.0 usb stick ? You can try plugging in another drive to single out the problem.
    Good luck :)
  • I stumbled here looking for an answer to that same issue. I have a 3TB USB3 external harddrive hooked up to the modem and I can only get a speed of 930KB/s when transfering a 1GB file to it.
    I used to have a DLINK DIR-865 router with a similar USB3 plug for an external hard drive and I was getting a transfer speed of 11MB/s with the same 3TB hard drive.
    I mean that plug on the back of the modem really is USB3, right? It does say so on the Hitron CODA-4680 web page.
    I guess I should upload the hard drive content to cloud storage then? The upload speed it faster than 930KB/s
  • poker85
    poker85 Posts: 778
    Yes it's very slow. Sorry but is the modem... not your DD
  • How do we access a USB shared drive on this Hitron 4680 ???

    I thought it was possible with file manager on windows 7 but why does FILE MANAGER on WINDOWS shows CODA-4859 on the Network ? 😮

    On Linux Mint with Caja I was able to see file://192.168.0.1/diska1

    and the HELP button says :

    Samba Setting Guide

    Introduction

    USB Storage page shows you how to setup USB disk sharing through LAN interface.


    The gateway support the user to plug in a USB flash disk for sharing through the LAN interface.

    The file systems supported include the Window's FAT16, FAT32 and NTFS.

    Those file systems could be mounted and shared with samba protocol as the network neighbor storage.

    When the disk is plugged in, each partition on the disk would be mounted as a seperated disk and shared.

    The gourp means Window's workgroup ID. If users change it, please press the Apply button after the modification. Users could press the hyperlink of the shared Disk to open the folder, for example, Shared Disk1.

    After changing the settings, click the 'Save changes' button to make the settings effective.


    I also tried to connect to file://192.168.0.1/diska1 by six different protocol with Caja on Linux Mint ?

    No way.

    I am at a loss.

    Thanks for your help.

  • ThinQ
    ThinQ Posts: 8

    Were you able to get access? I wasn't able to see my drive at all..