Trying to call Cuba from Canada but it does not work

Hi -

I've added funds in my wallet to make international calls to Cuba but it is not working - I have tried calling the same number through another cell provider and it works - So Fizz is blocking the call -


How do I unblock this - * I verified in my settings and blocking international calls is not activated.


Please advise.

Answers

  • DinoS
    DinoS Referral Code: M7IQ8Posts: 614

    Probably it's in Cuba site. Did you use 011+ country code + phone number format ?

  • Hi - Yes I have done this !!

  • Isabelle_33424
    Isabelle_33424 Code de référence H68KKPosts: 188

    You need to activate the International calls option of your plan. To do so:

    1. Go to My Plans in your Fizz account.
    2. If there is more than one plan on your account, scroll to the plan you wish to change.
    3. Click on Manage and choose Advanced parameters.
    4. Next to No International calls, slide the radio button to Off.


  • It's off already!

  • Isabelle_33424
    Isabelle_33424 Code de référence H68KKPosts: 188

    Than I would recommend that you check with technical support directly :

    Log in to your account

    Go to this page https://fizz.ca/en/faq/im-unable-log-my-fizz-account-what-do-i-do

    Wait 5 seconds for the bubble "?" icon to appear at the bottom right of the browser and click on the icon to chat with support. (The business hours are every day from 8 a.m. to 9 p.m. (EST).)

  • Hi - Update for those who need to know--

    Fizz does not offer international calls to Cuba.


    This is the reason it doesn't work!!