If you are looking for something specific, please use the search bar to check if someone else has asked or answered the same question before posting a new question.

Random devices kicked off network or unable to connect to wifi (authentication errors)?

Since about 3 months ago, random devices are unable to connect to my wifi network. I have both my home and guest network, as well as the 2.4 ghz and no matter which device is having the issue, it won't connect to any of the 3 networks available. I also tried turning off band steering and that didn't help. Each time I have very strong wifi signal, so signal strength doesn't seem to be the issue. My internet plan is 120 mbps.
About 1 month ago I factory reset the modem and it fixed the issue maybe for 2 weeks. Yesterday & today have been the worst of all. Yesterday my phone was connected on my wifi network, and suddenly mid-video call I got kicked off the network. My device then was not able to reconnect (I did a quick restart of the modem which resolved the issue).
I had seen in another forum that some people said their phones had connectivity issues and had resolved it by turning off randomized mac in their phone's wifi settings. That did not help either.
This morning my laptop would not connect to the router, but my phone was connected without issue. I restarted the modem and then they were both connected for about 2 minutes. After that, both devices were kicked off the network and unable to connect. I had to restart the modem a second time, this time only reconnecting my laptop to avoid being booted off a third time.
I could do another factory reset, but with any of my previous ISPs, I only had to do a factory reset maybe once or twice during that service (and we're talking years going without resetting the modem). Any assistance would be greatly appreciated as I am highly contemplating changing providers. This is becoming a nuisance and I shouldn't be experiencing this many interruptions of my service nor should I have to reboot/reset my modem at this frequency.

Answers

  • Whizz
    Whizz Posts: 7,846
    Hello Sarah,
    Thank you for the detailed explanation of the situation that you encountered.
    Because you have posted it on the community forum, I will provide you a short brief of your current situation. I would strongly recommend that you contact us on our more private contact methods for a more detailed or faster analysis.
    The disconnection that you are experiencing, can be because of the guess network that you have created. When you create a guess network, it weakens your whole connection and lets unknown devices make use of your network without you knowing.
    I would strongly suggest you set the modem to its factory settings and only use the wi-fi as it is, or disable the band steering and use both frequencies equal.
    I suggest you follow some of the steps from the FAQ https://fizz.ca/en/faq/my-wi-fi-network-cutting-how-do-i-fix-it , also, you can find our contact methods on the lower right-hand side by pressing on the question mark.
    Regarding the modem restarts or needing to do the resets, please keep in mind that unknown devices can access the network, exactly as I've mentioned earlier, and kick your devices out of the network because they need the bandwidth.
    Stay safe and take care!
    -Bogdan
This discussion has been closed.