If you are looking for something specific, please use the search bar to check if someone else has asked or answered the same question before posting a new question.

BMO.com app and website not working.

I have read other similar questions from two months ago that say "resolved" but for me the solution didn't resolve my issue. I have cleared all cache, cookies, history from chrome but I still have "Lost Connection" when trying to access the BMO app (this has happened on two separate occasions) and I get a 404 error when trying to access BMO.com.

Answers

  • Mike
    Mike Posts: 18,409
    There was an other post, one suggestion was to uninstall the app and reinstall.
    404 it means that the server was UP but the page was not there very strange.
    Add (from android store the comment of 19/3/2019)
    This app has gotten bad since the last update. Login screen doesn't even work, instead it always says something avout ny connection even though my wifi & data work for every other app/website seamlessly. Deleted the app and tried downloading again multiple times but nothing has changed.
  • TheMMc
    TheMMc Posts: 489
    It's probably BMO who got trouble with theire servers or the app.
  • If it's working for other sites and not working for the app, nor the BMO website, it should be BMO
  • GyslainH
    GyslainH Posts: 311
    it's not a fizz issue its a BMO issue
  • I haven't heard of any other service providers having this issue. Only fizz.
This discussion has been closed.